Allgemeines

LgZINSEN

Tel. 034742 - 71831

eMail: dirktinz@aol.com

Internet: http://www.dirktinz.de

Internet: http://www.dirktinz.com

Programmiert mit DELPHI 2.0/3.0/5.0 von BORLAND GmbH Deutschland.

Hier finden Sie Hinweise zur Freischaltung per eMail.


Vorgehensweise

LgZINSEN

Vorgehensweise

Diese Hinweise gelten für jene Nutzer, die die Freischaltung von ZINSBERECHNUNGEN per eMail vornehmen lassen. Für die Nutzer, die eine CD bestellen, sind diese Hinweise irrelevant, weil dort die Freischaltdatei automatisch mit installiert wird. Alle Erklärungen beziehen sich auf die Freischaltung von ZINSBERECHNUNGEN mit der Version V10.x.

Manchmal kommt es vor, dass eine Freischaltung per eMail nicht richtig funktionieren will. Dafür kommen folgende Gründe in Betracht:

n Version der Freischaltdatei und Version des freizuschaltenden Programmes sind unterschiedlich. In so einem Fall benutzen Sie nicht die richtige Version von ZINSBERECHNUNGEN. Das kann daran liegen, dass Sie einen KEY für eine ältere Version haben, der aber NICHT für die neue Version funktioniert. Ein KEY funktioniert immer nur für eine Versionsreihe (gleiche Hauptversionsnummer). Oder Sie haben einen aktuellen KEY aber eine frühere Version aus dem Internet herunter geladen und diese installiert. Wer also die Version V10 frei schalten will, muss die dazugehörige Freischaltdatei haben und natürlich die Version 10 von ZINSBERECHNUNGEN installiert haben. Die Freischaltdatei erhalten Sie vom Programmautor. Die Version des installierten Programmes können Sie folgendermaßen überprüfen:

Version der installierten Programmversion überprüfen

Die Version der Freischaltdatei können Sie so überprüfen (vorsichtig - nichts speichern)

Version der Freischaltdatei überprüfen
n Die Freischaltdatei wurde in den falschen Ordner kopiert. Es ist unbedingt notwendig, dass die Schlüsseldatei "zinsen.key" auch in den Ordner kopiert wird, in welchem das Finanzprogramm ZINSBERECHNUNGEN installiert wurde. Normalerweise ist dies

c:\programme\zinsen10

Wenn Sie einen anderen Ordner gewählt haben, müssen Sie die Schlüsseldatei ZINSEN.KEY auch in diesen Ordner kopieren.

Ordner vom Programm überprüfen
n Das eMail-Programm benennt die Freischaltdatei um. Dies passiert besonders Nutzern die mit Outlook arbeiten. Die Freischaltdatei muss immer "zinsen.key" heißen. Weil die eMail-Adresse des Autors "dirktinz@aol.com" heißt, kann es vorkommen, dass die Datei in "dirktinz.doc" umbenannt wird. Sollte es Ihnen NICHT gelingen, die Datei zurück zu benennen, wenden Sie sich an den Autor. Er wird die Datei dann auf seiner Internetseite mit einem geheimen Downloadlink für Sie kurzzeitig zum Download bereit stellen.
n Das eMail Programm löscht die Freischaltdatei. Auch dies wird mit Vorliebe von Outlook vorgenommen. Dies liegt daran, dass Microsoft den Dateityp ".KEY" später (also nach dem Autor) als gleichen Typ benutzt wie die Registrierungsdateien des Systems, die die Dateierweiterung ".REG" haben. Im Prinzip ist das unsinnig, gibt es doch den Typ ".REG" dafür. Daher nimmt das eMail-Programm an, dass es sich um eine REG-Datei handelt, die "böse Einträge" auf Ihrem System vornehmen will. Und in der Tat ist das auch möglich aber nicht in diesem Fall. Weil die KEY-Datei des Autors ein ganz anderes Format hat und vom System nicht verstanden wird. Führt man nämlich trotzdem einen Doppelklick auf die Datei zinsen.key aus und beantwortet die Frage mit JA, so kommt die Meldung, dass das Hinzufügen fehlgeschlagen ist, weil es sich bei ZINSEN.KEY eben nicht um eine Systemregistrierungsdatei handelt. Aus diesem Grund soll auch auf die Freischaltdatei NIE doppelt angeklickt werden (auch nicht öffnen), sondern sie soll nur kopiert werden.
n Die Datei wurde NICHT gedownloaded, sondern geöffnet.

Hier finden Sie Hinweise zum korrekten Download

Woran erkennt man, dass alles richtig geklappt hat. Einfach das Programm starten und die farbige (Regenbogen) Titelzeile des Programmes ganz oben sehen. Hier darf NICHT "unregistrierte Sharewareversion" stehen, sondern muss der Lizenzname (hier "Bernd Stein" = frei erfunden) zu sehen sein.


Ordner des Programmes überprüfen

LgZINSEN

Ordner des Programmes überprüfen

Es ist unbedingt notwendig, dass die Schlüsseldatei "zinsen.key" auch in den Ordner kopiert wird, in welchem das Finanzprogramm ZINSBERECHNUNGEN auch installiert wurde. Normalerweise ist dies

c:\programme\zinsen10

Wenn Sie einen anderen Ordner gewählt haben, müssen Sie die Schlüsseldatei auch in diesen Ordner kopieren. Den Ordner können Sie auf zwei Arten ermitteln:

1. Ermitteln des Ordners mit Hilfe des Programmes selbst

Starten Sie das Programm ZINSBERECHNUNGEN. Klicken Sie im Menü auf "Datei" und dann auf "Öffnen"

Es erscheint die Auswahlbox zum Öffnen für Dateien. Wir wollen aber keine Datei öffnen, sondern nur mit Hilfe dieser Auswahlbox feststellen, wo sich das Programm ZINSBERECHNUNGEN befindet.

Ganz oben sehen Sie eine ComboBox in welcher der Ordner "Documents" steht. Klicken Sie einfach auf das kleine schwarze Dreieck zum Öffnen der Liste. Man sieht nun folgendes:

An dieser Liste kann man absehen, wo sich das Programm auf Ihrem PC befindet. Hier sieht man zum Beispiel, dass sich das Programm auf Laufwerk C: (Windows) befindet, im Unterordner "Programme" und dort im Ordner "Zinsen10". In diesen Ordner muss also auch die Schlüsseldatei zinsen.key kopiert werden. Der zuvor erwähnte Ordner "Documents" ist nämlich ein Unterordner von ZINSBERECHNUNGEN.

2. Ermitteln des Ordners mit Hilfe des WINDOWS-Explorers

Die zweite Methode hat den Vorteil, dass man gleich die Version überprüfen kann. Manch einer vergisst das, befolgt dann stur die Installationsanweisungen aus der eMail und wundert sich, dass die Freischaltung nicht funktioniert. Zuerst starten Sie den normalen WINDOWS-Explorer, indem Sie mit der rechten Maustaste auf den START-Button von WINDOWS klicken. Es erscheint dann ein Auswahlmenü, dass etwa so aussieht:

Wählen Sie hier den Eintrag "Explorer" und klicken Sie diesen normal an, so dass das Programm dann startet. Wenn man dann den Arbeitsplatz wählt, erhält man im linken Fenster dann etwa folgende Ansicht:

Wechseln Sie nun in den Ordner, in welchem sich das Programm, welches frei geschaltet wird (hier ZINSBERECHNUNGEN) befindet. Normalerweise ist dies
c:\programme\zinsen10
Sollten Sie bei der Installation einen anderen Zielordner gewählt haben, müssen Sie natürlich dahin wechseln (notfalls etwas suchen). Diese Hilfedatei geht davon aus, dass Sie dass Programm in den oben genannten Pfad installiert haben. Wenn Sie in den Ordner gewechselt haben, müssen Sie im rechten Fenster des Explorers folgenden Dateien und Verzeichnisse sehen. Wichtig sind für uns die beiden Dateien mit dem blauen "Z" [image] . Eine von den beiden ist eine harmlose ICO-Datei (Typ Symbol) und die andere ist das Programm. Sie bekommen das leicht heraus, wenn Sie den Mauszeiger über beide der Dateien bewegen.

Wenn Sie nämlich den Mauszeiger über das Programm bewegen, sieht man die Programmversion.

Die Dateiversion muss hier mindestens mit einer 10 beginnen. Alternativ kann man auch mit der rechten Maustaste auf die Programmdatei klicken und in dem erscheinenden Menü den Befehl Eigenschaften wählen.


Hinweise zum Download der Schlüsseldatei

LgZinsen

Hinweise zum Download der Freischaltdatei

Bis zur Version V10.x hatte die Freischaltdatei die Dateierweiterung ".KEY". Als Microsoft diese Dateierweiterung für seine Registrierungsdateien mit reservierte (was völlig blödsinnig war, da Registrierungsdateien allgemein die Dateierweiterung ".REG" besitzen), kam es zu Problemen, wenn User nach dem Download der Freischaltdatei einen Doppelklick auf dieselbe ausführten. WINDOWS interpretierte diese dann als Eintragungen für die Systemregistrierung, was diese Datei nicht war und auch nicht enthielt. Obwohl es zu keinen Systemfehlern führte, brachte ein Doppelklick und ein Versuch die Datei zu Öffnen immer eine Fehlermeldung ein.

Es ist unbedingt notwendig, dass die Schlüsseldatei "zinsen.key" NUR gedownloaded und nicht geöffnet wird. Sollte die Schlüsseldatei von der Homepage des Autors herunter geladen werden (dies geht nur nach vorherigem Link), dann sieht man folgenden Dialog:

Es muss also auf Speichern geklickt werden. Als Zielort muss dann den Ordner wählen, in welchem das Programm zuvor installiert wurde.

Ab der Version V11.x wurde die Dateierweiterung für die Freischaltung in ".FREE" umbenannt, was nun keine Konflikte mehr auslöst. Öffnen sollte man die Datei immer noch nicht. Zwar führt das nicht zu Fehler, ist aber eine sinnlose Maßnahme. Denn die Datei wird nur vom freizuschaltenden Programm erkannt und muss deshalb in den gleichen Ordner wie das Programm kopiert werden.


Version des Programmes feststellen

LgZINSEN

Version des Programmes ermitteln

Zuerst sollten Sie überprüfen, ob überhaupt die richtige Version vorliegt. Dies kann man mit Hilfe des Programmes selbst abfragen oder mit Hilfe des WINDOWS-Explorers.

1. Versionsermittlung mit Hilfe des Programmes

Starten Sie das Programm ZINSBERECHNUNGEN. Klicken Sie im Menü auf Hilfe und dann auf Info.

Nach Klicken auf Info erscheint die Informationsbox von ZINSBERECHNUNGEN. Hier sehen Sie die Hauptversionsnummer als auch die Unterversionsnummer und sogar die Revision.

Man sieht dass die Hauptversionsnummer die 10 ist. Die Unterversionsnummer (Nebenversion) ist die 6, die Ausgabeversion ist die 1 und die Buildnummer ist die 0. Wichtig ist nur die Hauptversionsnummer, die in unserem Beispiel 10 betragen muss (was sie hier auch vorliegt).
2. Versionsermittlung mit Hilfe des WINDOWS-Explorers

Die zweite Methode hat den Vorteil, dass man gleich überprüfen kann, in welchem Ordner man das Programm ZINSBERECHNUNGEN überhaupt hin installiert hat. Manch einer vergisst das, befolgt dann stur die Installationsanweisungen aus der eMail und wundert sich, dass die Freischaltung nicht funktioniert. Zuerst starten Sie den normalen WINDOWS-Explorer, indem Sie mit der rechten Maustaste auf den START-Button von WINDOWS klicken. Es erscheint dann ein Auswahlmenü, dass etwa so aussieht:

Wählen Sie hier den Eintrag "Explorer" und klicken Sie diesen normal an, so dass das Programm dann startet. Wenn man dann den Arbeitsplatz wählt, erhält man im linken Fenster dann etwa folgende Ansicht:

Wechseln Sie nun in den Ordner, in welchem sich das Programm, welches frei geschaltet wird (hier ZINSBERECHNUNGEN) befindet. Normalerweise ist dies
c:\programme\zinsen10
Sollten Sie bei der Installation einen anderen Zielordner gewählt haben, müssen Sie natürlich dahin wechseln. Diese Hilfedatei geht davon aus, dass Sie dass Programm in den oben genannten Pfad installiert haben. Wenn Sie in den Ordner gewechselt haben, müssen Sie im rechten Fenster des Explorers folgenden Dateien und Verzeichnisse sehen. Wichtig sind für uns die beiden Dateien mit dem blauen "Z" [image] . Eine von den beiden ist eine harmlose ICO-Datei (Typ Symbol) und die andere ist das Programm. Sie bekommen das leicht heraus, wenn Sie den Mauszeiger über beide der Dateien bewegen.

Wenn Sie nämlich den Mauszeiger über das Programm bewegen, sieht man die Programmversion.

Die Dateiversion muss hier mindestens mit einer 10 beginnen. Alternativ kann man auch mit der rechten Maustaste auf die Programmdatei klicken und in dem erscheinenden Menü den Befehl Eigenschaften wählen. In dem dann zu sehenden Fenster wählt man die Karte Version:

Auch hier kann man die Version problemlos ablesen. Sollten Sie aus Versehen auf eine andere Datei mit der rechten Maustaste geklickt haben, dann fehlt die Seite "Version" in dem obigen Fenster. Diese Versionsseite ist NUR bei ausführbaren Programmen und Bibliotheken von SERIÖSEN Programmautoren vorhanden.


Version der Freischaltdatei feststellen

LgZINSEN

Version der Freischaltdatei feststellen

Mit Hilfe eines kleinen Tricks, kann man auch die Version der Freischaltdatei feststellen. Sie muss einfach nur mit dem Windows-Editor geöffnet werden. Aber auf gar keinen Fall darf Sie gespeichert werden, dann ist sie nämlich hin und taugt zu gar nichts mehr. Also nur Öffnen und nachsehen, dann schließen. Die Freischaltdatei ZINSEN.KEY erkennt man an dem kleinen Würfelsymbol, die Datei ZINSEN.FREE hat keinerlei spezielles Symbol:

Wenn Sie den Windows-Editor (unter Zubehör) starten, müssen Sie den Dateityp auf "Alle Dateien" stellen, denn standardmäßig erkennt der Editor natürlich nur Textdateien. Alternativ kann man auch im Windows-Explorer mit der rechten Maustaste auf die Schlüsseldatei klicken und dann auf "Bearbeiten".

Wenn sich der Editor dann öffnet sieht man folgendes:

Hier sieht man die Versionsnummer (hier 10er Reihe) und den Lizenzname. Wie gesagt auf keinen Fall speichern!